New beta version of Bet Angel v1.59.0 - Now on general release

Post Reply
User avatar
Euler
Posts: 22675
Joined: Wed Nov 10, 2010 1:39 pm
Location: Bet Angel HQ

You can use steaming or polling. You can select from the communications settings.
User avatar
jamesedwards
Posts: 1126
Joined: Wed Nov 21, 2018 6:16 pm

Euler wrote:
Mon Jun 20, 2022 8:26 pm
You can use steaming or polling. You can select from the communications settings.
Are there ever any benefits to using polling over streaming?
sniffer66
Posts: 1138
Joined: Thu May 02, 2019 8:37 am

jamesedwards wrote:
Mon Jun 20, 2022 8:44 pm
Euler wrote:
Mon Jun 20, 2022 8:26 pm
You can use steaming or polling. You can select from the communications settings.
Are there ever any benefits to using polling over streaming?
Only one I can think of, is over 1000 markets loaded and can't be arsed/not enough power to run multiple BA's
User avatar
jamesedwards
Posts: 1126
Joined: Wed Nov 21, 2018 6:16 pm

sniffer66 wrote:
Mon Jun 20, 2022 8:49 pm
jamesedwards wrote:
Mon Jun 20, 2022 8:44 pm
Euler wrote:
Mon Jun 20, 2022 8:26 pm
You can use steaming or polling. You can select from the communications settings.
Are there ever any benefits to using polling over streaming?
Only one I can think of, is over 1000 markets loaded and can't be arsed/not enough power to run multiple BA's
That's interesting. Do you mean the 1000 market limit is only for streaming? And can I run more than 1000 markets on one Guardian if I am polling?
User avatar
Dabbla
Posts: 521
Joined: Wed Apr 15, 2009 1:50 pm

jamesedwards wrote:
Mon Jun 20, 2022 6:35 pm
Bet Angel wrote:
Mon Jun 20, 2022 2:37 pm
jamesedwards wrote:
Thu Jun 02, 2022 12:31 am
I think I have identified a bug when using both positive and negative numbers in the same value based background colour setting.
We haven't been able to recreate this issue, so if you're seeing the issue please e-mail support and we can discuss it further.
I've been able to recreate this easily. See below the screenshot, rulesfile and guardian layout file. Perhaps I am making an elementary error?

I've also emailed these to BA support as requested.

test screenshot.PNG

There is/was a bug when using the whitest white from the colour picker. I thought the issue only happened when using a number between 0-1, may have been below 1 or 0. I posted about it at the time, Im pretty sure this is the same issue.
Assuming your using the whitest white, try change that to a slightly darker white.
If it’s the same issue ,that should fix it.
User avatar
jamesedwards
Posts: 1126
Joined: Wed Nov 21, 2018 6:16 pm

Dabbla wrote:
Mon Jun 20, 2022 9:09 pm
jamesedwards wrote:
Mon Jun 20, 2022 6:35 pm
Bet Angel wrote:
Mon Jun 20, 2022 2:37 pm


We haven't been able to recreate this issue, so if you're seeing the issue please e-mail support and we can discuss it further.
I've been able to recreate this easily. See below the screenshot, rulesfile and guardian layout file. Perhaps I am making an elementary error?

I've also emailed these to BA support as requested.

test screenshot.PNG

There is/was a bug when using the whitest white from the colour picker. I thought the issue only happened when using a number between 0-1, may have been below 1 or 0. I posted about it at the time, Im pretty sure this is the same issue.
Assuming your using the whitest white, try change that to a slightly darker white.
If it’s the same issue ,that should fix it.
Support just came back to me on email to say the same thing. Sure enough, I changed my background colour from 255 255 255 to 254 254 254 and the problem is resolved. Thanks for the info.
sniffer66
Posts: 1138
Joined: Thu May 02, 2019 8:37 am

jamesedwards wrote:
Mon Jun 20, 2022 8:54 pm
sniffer66 wrote:
Mon Jun 20, 2022 8:49 pm
jamesedwards wrote:
Mon Jun 20, 2022 8:44 pm


Are there ever any benefits to using polling over streaming?
Only one I can think of, is over 1000 markets loaded and can't be arsed/not enough power to run multiple BA's
That's interesting. Do you mean the 1000 market limit is only for streaming? And can I run more than 1000 markets on one Guardian if I am polling?

Yup, I sometimes switch over on a Saturday when the footy goes mad at 3pm. But only when the extended refresh isn't an issue
User avatar
jamesedwards
Posts: 1126
Joined: Wed Nov 21, 2018 6:16 pm

sniffer66 wrote:
Mon Jun 20, 2022 9:26 pm
jamesedwards wrote:
Mon Jun 20, 2022 8:54 pm
sniffer66 wrote:
Mon Jun 20, 2022 8:49 pm


Only one I can think of, is over 1000 markets loaded and can't be arsed/not enough power to run multiple BA's
That's interesting. Do you mean the 1000 market limit is only for streaming? And can I run more than 1000 markets on one Guardian if I am polling?

Yup, I sometimes switch over on a Saturday when the footy goes mad at 3pm. But only when the extended refresh isn't an issue
Thanks very much for the info. I will do the same when I need to. I've always had to open up another Guardian in the past.
Bet Angel
Bet Angel
Bet Angel
Posts: 3924
Joined: Tue Apr 14, 2009 3:47 pm

Dabbla wrote:
Mon Jun 20, 2022 7:47 pm
Im using streaming.
If you look at this screenshot, concentrate on the 2nd and 3rd guardian. These 2 are using exactly the same BA setting, automation, ect.
missing winners.PNG
The same races are side by side, some of the winners (alert 5) are populated, some are not. So I can pretty much rule out that the file is failing. The rules have triggered in one guardian but not the other.
We've had your rule running all day and it's detected the closed market and displayed the Winner properly apart from a single race, the 20:10 Philadelphia market. I'm not sure if anything unusual happened to the stream on that race, but now that we've been able to see it in person we'll add loads of logging and try to work out what's happening. May take some time as it's obviously a rare occurrence, but leave it with us.
User avatar
jamesedwards
Posts: 1126
Joined: Wed Nov 21, 2018 6:16 pm

Bet Angel wrote:
Tue Jun 21, 2022 9:22 pm
Dabbla wrote:
Mon Jun 20, 2022 7:47 pm
Im using streaming.
If you look at this screenshot, concentrate on the 2nd and 3rd guardian. These 2 are using exactly the same BA setting, automation, ect.
missing winners.PNG
The same races are side by side, some of the winners (alert 5) are populated, some are not. So I can pretty much rule out that the file is failing. The rules have triggered in one guardian but not the other.
We've had your rule running all day and it's detected the closed market and displayed the Winner properly apart from a single race, the 20:10 Philadelphia market. I'm not sure if anything unusual happened to the stream on that race, but now that we've been able to see it in person we'll add loads of logging and try to work out what's happening. May take some time as it's obviously a rare occurrence, but leave it with us.
If it helps the winner and P&L info for that race polled correctly for me at 20:35:56. The race went in play at 20:26:19 and was suspended at 20:28:06
Bet Angel
Bet Angel
Bet Angel
Posts: 3924
Joined: Tue Apr 14, 2009 3:47 pm

Bet Angel wrote:
Tue Jun 21, 2022 9:22 pm

We've had your rule running all day and it's detected the closed market and displayed the Winner properly apart from a single race, the 20:10 Philadelphia market. I'm not sure if anything unusual happened to the stream on that race, but now that we've been able to see it in person we'll add loads of logging and try to work out what's happening. May take some time as it's obviously a rare occurrence, but leave it with us.
In the Sunderland 19:41 race tonight we saw an example where the rules executed properly, but the Winner alert was still blank.
That's because they swapped out 'Sunset Nova' in Trap 6 and replaced it with 'Tenerifetropical'.
We don't handle the replacement of runners without manual removal/addition of the market from/to Bet Angel, but this is a different scenario to what you saw where the rules failed to trigger on market closure. We'll keep testing, but just wanted to point out that runner replacement is one possible cause of blank Winner names.
User avatar
Dabbla
Posts: 521
Joined: Wed Apr 15, 2009 1:50 pm

Bet Angel wrote:
Wed Jun 22, 2022 8:21 pm
Bet Angel wrote:
Tue Jun 21, 2022 9:22 pm

We've had your rule running all day and it's detected the closed market and displayed the Winner properly apart from a single race, the 20:10 Philadelphia market. I'm not sure if anything unusual happened to the stream on that race, but now that we've been able to see it in person we'll add loads of logging and try to work out what's happening. May take some time as it's obviously a rare occurrence, but leave it with us.
In the Sunderland 19:41 race tonight we saw an example where the rules executed properly, but the Winner alert was still blank.
That's because they swapped out 'Sunset Nova' in Trap 6 and replaced it with 'Tenerifetropical'.
We don't handle the replacement of runners without manual removal/addition of the market from/to Bet Angel, but this is a different scenario to what you saw where the rules failed to trigger on market closure. We'll keep testing, but just wanted to point out that runner replacement is one possible cause of blank Winner names.
The last couple of days, I have been running a few files on all the horse racing. No bets were placed either day. Everything triggered fine, 100% results , except 1 ,but I’ll put that down to human error.
Today I loaded 15 races into guardian, I trade 9 of them. 3 from that 9 failed.
I was tinkering with some files during this session, so that may have played apart. Although I think that may have only effected 1 of the results.

The one thing that stands out, the ones that failed had P&L / Matched bets.
Im wondering if it could have something to do with it.
I’ll keep an eye on it, see spot anything else.
Bet Angel
Bet Angel
Bet Angel
Posts: 3924
Joined: Tue Apr 14, 2009 3:47 pm

Dabbla wrote:
Wed Jun 22, 2022 9:25 pm
The last couple of days, I have been running a few files on all the horse racing. No bets were placed either day. Everything triggered fine, 100% results , except 1 ,but I’ll put that down to human error.
Today I loaded 15 races into guardian, I trade 9 of them. 3 from that 9 failed.
I was tinkering with some files during this session, so that may have played apart. Although I think that may have only effected 1 of the results.

The one thing that stands out, the ones that failed had P&L / Matched bets.
Im wondering if it could have something to do with it.
I’ll keep an eye on it, see spot anything else.
That's interesting. Were you trading on the same instance of Bet Angel that was running the rules to extract the Winner results? Were you trading manually or was it just that you'd attached an additional rules file to the markets that was placing bets, or was it that you switched to a rules file that both traded AND gathered Winner info?
User avatar
Dabbla
Posts: 521
Joined: Wed Apr 15, 2009 1:50 pm

Bet Angel wrote:
Thu Jun 23, 2022 10:24 am
Dabbla wrote:
Wed Jun 22, 2022 9:25 pm
The last couple of days, I have been running a few files on all the horse racing. No bets were placed either day. Everything triggered fine, 100% results , except 1 ,but I’ll put that down to human error.
Today I loaded 15 races into guardian, I trade 9 of them. 3 from that 9 failed.
I was tinkering with some files during this session, so that may have played apart. Although I think that may have only effected 1 of the results.

The one thing that stands out, the ones that failed had P&L / Matched bets.
Im wondering if it could have something to do with it.
I’ll keep an eye on it, see spot anything else.
That's interesting. Were you trading on the same instance of Bet Angel that was running the rules to extract the Winner results? Were you trading manually or was it just that you'd attached an additional rules file to the markets that was placing bets, or was it that you switched to a rules file that both traded AND gathered Winner info?

I only had 1 instance open yesterday.
There were 3 files were running on it, (Alert file) this contains the extract the Winner, My main file, a WOM algo that I was testing. All bets were placed manually / servant. None of the files placed bets.
Normally there are quite a lot of auto bets when it fails. So I don’t think how the bets are placed will make a difference.
Of the markets that failed 2 of them had 10 bets the other had 25.
10 to 25 bets were also the range of bets for the ones that didn’t fail.

I have loaded todays races in guardian at 15.45 ,Ill leave it running for a while and trade a few markets a bit latter, see what happens
User avatar
Dabbla
Posts: 521
Joined: Wed Apr 15, 2009 1:50 pm

Dabbla wrote:
Thu Jun 23, 2022 4:12 pm
Bet Angel wrote:
Thu Jun 23, 2022 10:24 am
Dabbla wrote:
Wed Jun 22, 2022 9:25 pm
The last couple of days, I have been running a few files on all the horse racing. No bets were placed either day. Everything triggered fine, 100% results , except 1 ,but I’ll put that down to human error.
Today I loaded 15 races into guardian, I trade 9 of them. 3 from that 9 failed.
I was tinkering with some files during this session, so that may have played apart. Although I think that may have only effected 1 of the results.

The one thing that stands out, the ones that failed had P&L / Matched bets.
Im wondering if it could have something to do with it.
I’ll keep an eye on it, see spot anything else.

That's interesting. Were you trading on the same instance of Bet Angel that was running the rules to extract the Winner results? Were you trading manually or was it just that you'd attached an additional rules file to the markets that was placing bets, or was it that you switched to a rules file that both traded AND gathered Winner info?

I only had 1 instance open yesterday.
There were 3 files were running on it, (Alert file) this contains the extract the Winner, My main file, a WOM algo that I was testing. All bets were placed manually / servant. None of the files placed bets.
Normally there are quite a lot of auto bets when it fails. So I don’t think how the bets are placed will make a difference.
Of the markets that failed 2 of them had 10 bets the other had 25.
10 to 25 bets were also the range of bets for the ones that didn’t fail.

I have loaded todays races in guardian at 15.45 ,Ill leave it running for a while and trade a few markets a bit latter, see what happens
Today I let guardian run from 15.45 till 21.00. Again everything was fine until I started trading.

The first race I traded failed, that was the 17.45. The race finished in a photo.
The second was the 18.30, I can’t see anything unusual,
The third was the 19.00. Looks like a close finish but no photo.

No files were altered during this session.
winwin.PNG
You do not have the required permissions to view the files attached to this post.
Post Reply

Return to “Bet Angel - Release & version history”